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Slika 243 Deo prirucnog menija koji se otvara kada desnim tasterom misa
pritisnete instancu na kruznom Sablonu

Pisanje teksta u okruzenju za skiciranje

CommandManager:  Sketch > Text (Doqajé__-?goriwk)
Meni: - Tools > Sketch Entities > Text :
Paleta alatki: Sketch > Text (Doda};e ‘korisnik)

U okruZenju za skiciranje moZzete pisati i tekst koji ée se kasnije koristiti
za izradu elemenata spoj (engl. join) i prosecanje (engl. cut). Da biste na-
| pisali tekst, pritisnite dugme Text na panou Sketch CommandManager;
pnkazace se pano za podeSavanje svojstava teksta - Sketch Text PropertyManager
(slika 244). Unesite tekst u polje na potpanou Text. Tekst ¢e podrazumevano
poceti od koordinatnog pocetka skice, ali ¢e bifi postavljen na mesto koje zadate na
ekranu pre nego $to ga napiSete ili posle toga. Pomocu opcija s potpanoa Text
mozZete promeniti format, font, poravnanje i druga svojstva teksta. Na slici 245 pri-
kazan je tekst dodat pomocu alatke Text.

Tekst mozete da postavite i duz krive. Da biste to uradili, prvo nacrtajte krivu.
To moze da bude Gk, slozena kriva, linija, ili kombinacija linije, ldka 1 sloZene
krive. Zatim otvorite pano Sketch Text PropertyManager, pa izaberite krivu ili
krive duz kojih hocete da postavite tekst. Unesite tekst u polje Text; tekst ce se
ispisati dnz krive. Orijjentaciju teksta moZete promeniti pomocu opcija Flip Hori-
zontal 1 Flip Vertical. Na slici 246 prikazan je tekst ispisan duz ldka.
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Slika 2-44  Pano xa podesavanje svojstava teksta — Sketch Text PropertyManager

CADCIM Technologies, USA

Slika 2-45 Skica napravijena alatkom Text

Slika 2-46  Tekst ispisan duz lika
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Modifikovanje skiciranih objekata

Vedinu skica treba u nekoj fazi rada izmeniti. Prema tome, vazno je da svi projek-
tanti razumeju proces izmena u programu SolidWorks. U nastavku se razmatra
modifikovanje razlicitih skiciranih objekata.

Modifikovanje skicirane linije
Skicirane linije se modifikuju pomodcu panoa Line Properties PropertyManager,
koji se prikazuje kada liniju izaberete alatkom Select. Ako je izabrana linija strani-
ca pravougaonika, poligona ili paralelograma, pri izmeni linije bice izmenjen ceo
objekat, zato §to su na sve stranice pravougaonika, poligona ili paralelograma pri-
menjene relacije.

Sli¢no tome, mozete izmeniti 1 ose simetrije pomocu panoa Centerline Pro-
pertyManager. koji ce se prikazati kada izaberete neku osu simetrije.

Modifikovanje skiciranog kruga

Da biste izmenili skiciran krug, izaberite ga alatkom Select; prikazace se pano
Sketched Circle PropertyManager s koordinatama centra kiruga i vrednoscu polu-
precnika tako da ih mozete izmeniti.

Savet. Stanje skiciranog objekta koji ste izabrali da biste ga izmenili pri-
kazuje se na polpanou Existing Relations aktivnog panoa PropertyMa-
nager. Na primer, ako je izabrani skicirani objekat potpuno definisan,
bice prikazan na panou. PrepertyManager, a ukoliko nije potpuno defi-
nisan, PropertyManager ce prikazati odgovarajucu poruku.

Modifikovanje skiciranog luka

Da biste izmenili skiciran 10k, izaberite ga alatkom Select; prikazace se pano Arc
PropertyManager, sa koordinatama centra, pocetne tacke i krajnje tacke luka.
Bice prikazane i vrednosti poluprecnika i obuhvadenog ugla. Sve ove koordinate i
vrednost moZete jzmeniti.

Modifikovanje skiciranog poligona

Da biste izmenili skiciran poligon, desnim tasteromn misa pritisnite bilo koju stra-
nicu poligona i otvorice se priru¢ni meni. Izaberite stavku Edit polygon; prikazace
se pano Polygon PropertyManager. Korii¢enjem opcija sa ovog panoa mozete
izmeniti izabrani poligon ili nacrtad nov.

Napomena
Ako desnim tasterom misa prilisnete referentnt krug koji se automatski iscriave
kada crtate poligon, opcija Edit polygon nece biti dostupna w privucnom meniju.
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Modifikovanje slozene krive

Na sloZenu krivu (engl. spling) mozete primeniti Sest vrsta izmena koje su detaljno
razmotrene u nastavku. To su: 1) modifikovanje krive pomocu kontrolnog poli-
gona; 2) promena koordinata izabrane kontrolne tacke; 3) dodavanje novih kon-
trolnih tacaka krivoj; 4) modifikovanje krive pomocu rucica (engl. spline handles);
5) dodavanje novih rucica; 6) dodavanje simbola zakrivljenosti.

Modifikovanje sloZzene krive pomoéu kontrolnog poligona

Kada u SolidWorksu 2006 izaberete krivu, na njoj se prikazuju Zuti kontrolni po-
ligoni koji se koriste za promenu oblika krive. Da biste na ovaj nacin izmenili krivu,
izaberite kontrolnu tacku kontrolnog poligona (slika 2-47).

Kontrofna tatka

kontrolnog puiigona\

Stika 2-47 Kontrolna tacka kontrolnog poligona

Prikazuje se pano Spline Polygon PropertyManager na kome mozete da izme-
nite koordinate kontrolne tacke. PoloZaj kontrolne tatke moZete promeniti ii tako
§to dete je povlaciti miSem.

Ako kontrolni poligon nije podrazumevano prikazan, izaberite krivu, pritisnite
desni taster mi§a i iz priruénog menija izaberite stavku Display Control Polygon.
Isti postupak se primenjuje 1 za isklju¢ivanje prikaza kontrolnog poligona.

Promena koordinata kontrolnih tacaka

Da biste izmenili kontrolnu tacku krive, izaberite je; otvorice se pano Spline Pro-
pertyManager, ¢iji je deo prikazan na slici 248. Bice prikazane sve kontrolne tacke
krive, a aktivna tacka bice oznacena malim kvadratom s popunjenim kruZicem.
Redni broj i koordinate aktivne rucice bice prikazani na panou Spline Property-
Manager. Koordinate se menjaju pomocu odgovarajuceg brojaca s panoa, a za
izbor druge rucice koristi se brojac Spline Point Number.
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Dodavanje kontrolnih tacaka

Da biste krivoj dodali kontrolne tacke, izaberite Tools > Spline Tools > Insert Splint
Point iz glavnog menjja. Drugi nacin je da izaberete krivu, pritisnete desni taster
misa i iz priru¢nog menija odaberete stavku Spline Point. Zatinm na krivoj izaberite
tacku koja treba da postane kontrolna tacka. Ta tacka ce biti oznacena kruzidem a iz
nje ¢e polaziti i rucica. O rudicama krivih vige cete saznati kasnije u ovom poglavlju.
Na isti nacin moZete dodati proizvoljan broj kontrolnih tacaka. Kada dodate potre-
ban broj tacaka, aktivirajte alatku Select pa ponovo izaberite kriva, Sve kontrolne
tacke bice oznacene kvadrati¢dima. Koordinate izabrane kontrolne tacke prikazuju
se u poljima brojaca na potpanou Parameters panoa Spline PropertyManager.
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Slika 248 Deo panoa Spline PropertyManager

Menjanje oblika krive pomocu rucica
Rucdica krive je linija sa strelicama u obe krajnje tacke. Rucice se prikazuju kada kri-
vu izaberete alatkom Select. Ruéice su podrazumevano sive, §to znadi da nisu iza-
brane. Kada postavite kursor iznad rudice, ona postaje crvena a ispod kursora sc
prikazuje dvostrana strelica. Izaberite ruicu kada bude crvene boje; postace zele-
na. Redni broj 1 koordinate izabrane kontrolne tacke bice prikazani na potpanou
Parameters. Povladite kursor da biste dinami¢ki menjali duZinu i pravac tangente.
Te vrednosti ¢e se dinamicki menjati i u poljima broja¢a Tangent Maguitude
odnosno Tangent Radial Direction. Opcija Tangent Driving automatski se uklju-
¢uje kada pocnete da povlacite kursor. Kada izmenite oblik krive, pritisnite bilo
gde u oblasti za crtanje da biste poniSuli tekucu selekciju. Rucica koju ste koristili
za menjanje oblika krive bice plava, §to ukazuje na to da je njena podrazumevana
postavka izmenjena. Na isti nacin moZete koristiti i ostale rucice.

U ovoj verziji SolidWorksa, ru¢icama krive mozete dodeliti parametarske mere
da biste precizno oblikovali krivu. Vise o dodeljivanju parametarskih mera sazna-
cete kasnije u ovom poglavlju.
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Dodavanje/brisanje rucica krive

Da biste dodali jo$ rucica, izaberite krivu, pritisnite desni taster mia i iz priruc¢nog
mendja odaberite stavku Add Tangency Control; prikazace se plava dvostrana stre-
lica, prikacdena za izabranu kiivu. Pomerite kursor na mesto na koje hocete da po-
stavite rudicu krive i u toj tacki pritisnite levi taster misa. Uz rucicu ce biti dodata
i kontrolna tac¢ka. Na rudice krivih mozete primeniti i relacije, o kojima cete vie
saznati u poglavlju 3. Rucice cete obrisad tako §to cete ih izabrati pa pritisnuti ta-
ster DELETE na tastaturi.

Dodavanje kontrole zakrivljenosti

Simbol kontrole zakrivljenosti (engl. curvature control symbol) koristi se za promenu
zakrivljenosu krive. Da biste dodali kontrolu zakrivljenosti, izaberite krivu, otvori-
te priruéni meni i odaberite stavku Add Curvature Control; za izabranu krivu bice
prikacen odgovarajudi simbol 7 . Pomerite kursor na mesto na koje hocete da
postavite simbol kontrole zakrivljenosti. U tu tacku, tangencijalno na krivu, bice
postavljena i rucica. Izaberite i povlacite kruZic koji se nalazi ispod ovog simbola.
Zakrivljenost krive ce se dinamicki menjati dok povlacite kursor. Kada izmenite
oblik krive. otpustite levi taster misa. Simbol zakrivljenosti krive obrisacete tako
$to Cete ga izabrati i pritisnuti taster DELETE na tastaturi.

Modifikovanje skicirane tacke

Da biste izmenili tacku na skici, izaberite je alatkom Select; prikazace se pano Sket-
ched Point PropertyManager, na kome moZete da promenite koordinate izabra-
ne tacke.

Modifikovanje elipse ili elipticnog lika

Da biste izmenili elipsu ili elipti¢an 1k, izaberite taj objekat alatkom Select; prika-
zace se pano Ellipse PropertyManager, na kome mozZete da promenite odgovara-
Jjuce parametre.

Modifikovanje parabole

Da biste izmenili parabolu, izaberite je alatkom Select; prikazace se pano Parabola
PropertyManager, na kome mozete da promenite odgovarajuce parametre
parabole.

Dinamicko menjanje i kopiranje skiciranih objekata

U okruZenju za skiciranje, skicirane objekte moZcte da izmenite ili kopirate dina-
micki - tako $to ih povladite uz pritisnut levi taster misa. Pretpostavimo da create
skicu pravougaonika i hocete da ga povecate. Treba samo da izaberete bilo koju
stranicu pravougaonika ili neko njegovo teme i da drZedi pritisnut levi taster misa
povlacite kursor. Kada dobijete pravougaonik koji vam odgovara, otpustite taster
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misa. Ako iz glavnog menija izaberete Tools > Sketch Setting > Detach Segment
on Drag i odaberete pravougaonik koji cete povladit, linijski segmenti (stranice
pravougaonika) bice odvojeni od pravougaonika. Ova opcija je podrazumevano is-
k}jucena tako da se pravougaonik povladi kao celina.

Skicirane objekte moZete i kopirati dinamicki. Jedan ili vise objekata koje hode-
te da kopirate izaberite pomocu tastera CTRL ili ith obuhvatite okvirom za izbor.
Driite pritisnut taster CTRL, pa drZeci pritisnut levi taster misa povlacite izabrane
objekte Na ekranu ce se videti prikaz kopiranih objekata. Otpustite levi taster misa
na mestu na koje hocete da smestite nove objekte. Ponavljanjem ovog postupka
mozele napravili vife kopija izabranih objekata.

Deljenje skiciranih objekata

CommandManager: Sketch > Split Entities (Dodaje korisnik)
Meni: Tools > Sketch Entities > Split Curve
Paleta alatki: Sketch > Split Curve (Dodaje korisnik)

Pomocu alatke Split Entities, skicirani objekal mo7ete podeliti na dva ili
viSe objekata tako $to cete zadad tacke deljenja. Da biste podelili obje-
ies kat, izaberite dugme alatke Split Entities s panoa Sketch Command-
Manager; tekuci kursor bice zamenjen kursorom podeljenih objekata. Postavite
kursor priblizno na mesto na kome Zelite da podelite objekat. Kada kursor prione
uz objekat, pritisnite levi taster misa da biste dodali tacku podele (engl. split point).
Zatim pritisnite desnj taster mi3a i iz priruénog menija izaberite stavku Select. Po-
mocu kursora za izbor odaberite skicirani objekat. Skicirani objekta bicc podeljen
na dva objekta izmedu kojih ce biti dodata tacka podele. MoZete dodati proizvoljan
broj tacaka podele. Da biste podelili krug, elipsu ili zatvorenu krivu, morate ih po-
deliti u najmanje dve tacke.

Ako obridete tacke podele, podeljeni objekti ponovo ¢e se spojiti u jedan obje-
kat. Da biste to uradili, izaberite tacku podele pa pritisnite taster DELETE na tasta-
turi. Drugi nadin je da desnim tasterom pritisnete tacku podele i da iz prirucnog
menija izaberete stavku Delete.,

Vezbe
Vezba 1

U ovoj vezbi nacrtacete osnovnu skicu za model sa slike 2-49. Skica modela pri-
kazana je na slici 2-50. Skicu osnovnog elementa nacrladete pomocu uobicajenih
alatki za skiciranje, a zatm dete je izmeniti pomocu razliéitih opcija za modi-
fikovanje.

(Ocekivano vreme: 30 min)






