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Opcija Equal distance

Kada je potvrdena opcija Equal distance (podrazumevand stanje), rastojanja zaru-

bljenja ista su u oba pravca. Ako iskljucite ovu opciju, za izradu zarubljenja mozZete

zadati dva razlicita rastojanja (slika 2-16). U tom sluéaju, ispod brojaca Distance 1

pojavljuje se brojac Distance 2, pomocu kojeg zadajete rastojanje u drugom pravcu.

Rastojanje 1 meri se duz prvog objekta koji ste izabrali, a rastojanje 2 - duZ drugog.
Razli¢ite nadine za izradu zarubljenja moZete pozivati i iz privu¢nog menija.

Napomena

Ako zarubljenje primenite na objekie za koje je pomocu relacije ili parametarske
mere zadat nek: uslov, prikazace se okvir sa sledecim upozorenjem: At least one
sketch constraint is about to be lost, Chamfer anyway? (Izgubice se najmange je-
dan uslov dodeljen skici. Da nastavim sa zarubljivanjem?) Pritisnite dugme Yes.
Vise o relacijama i merama hoje uslovljavaju izgled i ponasanje shice saznacete u
kasnifim poglavljima.

Kopiranje skiciranih objekata pomeranjem
na zadato rastojanje

CommandManager: Sketch > Offset Entities
Meni: Tools > Sketch Tools > Offset Entities
Paleta alatki: Sketch > Offset Entities

Kopiranje na zadato rastojanje (engl. offsetting) predstavlja jedan od naj-
lak$ih nacina crtanja paralelnih linija ili koncentri¢nih liikova i krugova.

| Moiete izabrati ¢itav niz objekata kao jedan objekat, ili izabrati jedan
objekat koji treba kopirati pomeranjem. Dosad je ova tehnika bila primenljiva samo
na skicirane objekte, ivice, petlje, povriine i krive. U ovoj verziji SolidWorksa,
moZete je primeniti 1 na parabolicne krive, elipse i elipti¢ne likove. Kada na paleti
Sketch Tools pritisnete dugme Offset Entities, prikazuje se pano Offset Entities
PropertyManager (slika 2-17). Sledi opis opcija s tog panoa.

Napomena

Ako hocele da obriSete tekucu selekciju dok obavljate bilo koju operaciju obrade,
desnim tasterom misa pritisnite povrSinu za crianje i iz prirucnog menija 1zabe-
rite stavkwu Clear Selections.

Opcija Offset Distance
Brojac¢ Offset Distance slwi za zadavanje pomeraja izabranog objekta. Vrednost po-
meraja moZete zadati pomocu brojaca ili poviacenjem objekta u oblasti za crtanje.

Opcija Add Dimension

Opcija Add dimension s potpanoa Parameters podrazumevano je potvrdena.
Kada je potvrdena, izmedu roditeljskog objekta i rezultujuceg, pomerenog objekta
dodaje se kota koja oznacava pormeraj.
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Stika 2-17 Pano Offset Entities PropertyManager

Opcija Reverse
Ukljucivanjem opcije Reverse menja se smer pomeranja. Kada objekte pomerate
pomocu misa, ne treba vam ova opcija jer sami birate kako cete pomerati objekat.

Opcija Select Chain

Ponrdite opciju Select chain da biste izabrali ceo niz kontinualnih skiciranih obje-
karta koji dodiruju izabrani objekat. Kada aktivirate alatku Offset, podrazumevano
ce biti uk]jucena opcija Select chain. Ako je iskljucite, bice pomeren samo izabrani
skicirani objekat.

Opcija Bi-directional

Kada je izabrano radio-dugme Bi-directional, izabrani objckat se kopira pome-
ranjem u oba smera, a polje za potvrdu Reverse u oblasti Parameters nece biti
dostupno.

Opcija Make Base Construction.
Opcija Make base construction sluZi za konvertovanje roditeljskog objekta ili
osnovnog objekta u konstrukcioni objekat.

Opcija Cap Ends
Polje za potvrdu Cap ends dostupno je samo ako je potvrdena opcija Bi-directio-
nal. Kada je uklju¢ena, opcija Cap ends zatvara krajeve objekata kopiranih pome-
ranjem u oba smera. MoZete jzabrati vrstu zavr$etka za krajeve. Ako pomerate
objekat koji je zatvoren na oba kraja, ova opcija nece biti dostupna.

Na slici 2-18 prikazan je nov niz objekata nastao kopiranjem izabranog niza ob-
jekata uz pomeranje, a na slici 2-19 - kopiranje jednog objekta pomeranjem.
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Nov objekat

. Prvobitni niz

. Novi niz (nakon kopiranja 1 ) .
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treba kopirati pomeranjem

Shka 2-18 Kopiranje niza objekala Slika 2-19  Kopiranje jednog objekta
pomeranjem na zadato rastojanje pomeranjem na zadato rastojanje

Simetricno preslikavanje skiciranih objekata

ComméndManager: Sketch > Mirror Entities
Meni: Tools > Sketch Tools > Mirror
Paleta alatki: Sketch > Mirror Entities

Alatka Mirror Entities sluZi za preslikavanje izabranih objekata, tj. za
dobijanje njihove slike u ogledalu. Objekti se preslikavaju oko ose sime-
trije. Kada preslikavate objekat, SolidWorks izmedu preslikanih obje-
kata uspostavlja relaciju simetri¢nosti. Ako jzmenite objekat, izmenice se i njegova
slika u ogledalu. Da biste preslikali postojece objekte, izaberite dugme alatke Mir-
ror Entities na panou Sketch CommandManager; prikazace se pano za podesa-
vanje svojstava preslikavanja - Mirror PropertyManager (slika 2-20).

Select entities ko mirror and &
| sketch line or linear model edge
o mirror about

Slika 2-20 Pano za podeSavanje svojstava preslikavanja — Mirror PropertyManager
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Program vas poziva da odaberete objekte za preslikavanje - 1zaberite ih u oblasti
za crtanje. Imena izabranih objekata bice prikazana u polju Entities to mirror.
Kada odaberete sve objekte koje hocdete da preslikate, pritisnite jednom u polju
Mirror about. Dok birate objekte, bice prikazan i simbol §B. Ako pritisnete desni
taster mi$a dok je ispod kursora prikazan ovaj simbol, automatski e se aktivirati
rezim izbora u sledecem polju. Program ce vas pozvati da izaberete liniju ili ravnu
ivicu modela kao osu za preslikavanje. U oblasti za crtanje izaberite liniju ili osu
simetrije koja e se koristiti za preslikavanje. Pojavice se privremeni prikaz preslika-
ne slike. Obavezno proverite da i je na panou Mirror PropertyManager potvrdena
opcija Copy. Ako isklju€ite tu opciju, nestace roditeljski objekti koji su izabrani za
preslikavanje a ostace samo preslikani objekti. Pritisnite dugme OK na panou Mir-
ror PropertyManager.

Na slici 2-2] prikazani su skicirani objekti sa osom simetrije, a na slici 2-22 - re-
zultat preslikavanja.
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Shika 2-21 Biranje skiciranih objekata  Skka 2-22  Skiru nekon preslikavanja
i ose simetrije

Preslikavanje pri skiciranju (dinamicki preslikani objekti)

CommandManage’r: Sketch > Dynamic Mirror Entities (Dodaje korisnik)
Meni: Tools > Sketch Tools > Dynamic Mirror
Paleta alatki: Sketch > Dynamic Mirror Entities (Dodaje korisnik)

Alatka Dynamic Mirror Entities koristi se za preslikavanje objekata
oko ose simetrije tokom skiciranja i preporucuje se za crtanje simetri¢-
nih skica. Da biste upotrebili ovu alatku, izaberite dugme Dynamic
M_lrror Entities na panou Sketch CommandManager; prikazace se pano Mirror
PropertyManager (slika 2-23).
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Stika 2-23 Pano Mirror PropertyManager
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Potpano Message panoa Mirror PropertyManager poziva vas da izaberete ski-
ciranu liniju ili ravnu ivicu modela kao osu oko koje cete preslikati objekte. Izabe-
rite je na crteZzu. Na oba Kraja ose simetrije pojavljuje sc simbol simetri¢nosti, koji
ukazuje na to da je aktivirano automatsko preslikavanje (slika 2-24). Poénite da c1-
tate skicu. Objekat koji nacrtate s jedne strane ose simetrije, automatski ce biti
nacrtan i s druge strane ose. Kao 3to se vidi na slici 2-25, objekti se automatski pre-
slikavaju pri crtanju skice. Na slici 2-26 prikazana je zavrSena skica sa automatskim
preslikavanjem.
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Shka 2-24  Osa simetrije i simbol simetricnosti wkazuju na to
da je aktivno automatsho preslikavanie
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Slika 2-25 Skiciranje uz aktivnu opcipe Shka 2-26  Skica nacrtana uz automatsko
automatskog preslikavanja preshkavanje

Napomena

Kada rzavrsite skicu uz horiSéenje automatshog preslikavanja, moZete isklyuditi
ovu opciju tako Sto cele pritisnutt dugme alatke Dynamic Mirror Entikies nu
panou Sketch CommandManager.




BLJE

Poglavlje 2: Obrada i izmena skica 79

Premestanje skiciranih objekata

CommandManager: Sketch > Move Entities
Meni: Tools > Sketch Tools > Move or Copy
Paleta alatki: Sketch > Move or Copy

Alatka Move Entities koristi se za premestanje izabranih objekata iz nji-
hovog prvobitnog poloZaja na Zeljeno mesto. Da biste to uradili, akti-
virajte alatku Move Entities tako $to cete izabrati istoimeno dugme
s panoa Sketch CommandManager. Ova alatka ce biti dostupna samo ukoliko je
nacrtan bar jedan objekat. Kada aktivirate alatku, prikazace se pano za podesa
vanje svojstava premestanja - Move PropertyManager (slika 2-27), i bice ponude-
no da izaberete skicirane objekte ili oznake (engl. annotations). Sledi opis opcija sa
ovog panoa.

Skiciranl objekti
ili oznake
Paameters &
% From|To
oty
Shark poirt
Bazna tatka

Sliha 2-27 Pano za podeSavange svojstava premestanja ~ Move PropertyManager

Potpano Entities to Move
Opcije sa ovog potpanoa koriste se za biranje objekata koje treba premestiti. Ak-
tivno je polje Sketch items or annotatious, u kome ¢e biti prikazana imena obje-
kata koji su izabrani radi premestanja. Da biste iz skupa izabranih objekata uklonili
neki objekat, ponovo ga izaberite u oblasti za crtanje. Drugi nacin je da izaberete
njegovo ime u polju Sketch items or annotations, pritisnete desni taster misa da
bi se otvorio priruéni meni i izaberete stavku Delete. Ako iz priru¢nog menjja jza-
berete stavku Clear Selection, ponisticete izbor svih objekata iz datog skupa.
Opcija Keep relations je podrazumevano iskljuéena. Ako premestate skicirane
ohjekte dok je ova opcija iskljucena, uklanjaju se relacije koje su primenjene na te
objekte. Ukoliko potvrdite ovu opciju a zatiro premestite objekte, pridruzene rela-
cije se zadr7avaju i nakon premestanja. Vise o relacijama saznacete u poglavlju 3.
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Potpano Parameters
Potpano Parameters koristi se za zadavanje prvobitnog 1 odredi$nog polozaja ski-
ciranih objekata koje premestate. Sledi opis opcija sa ovog panoa.

Opcija From/To

Radio-dugme From/To podrazumevano je izabrano i omogucava da izabrane
objekte premestate od jedne tacke do druge. Da biste objekte premestili pomocu
ove opcije, pritisnite jednom polje Base point; program poziva da zadate baznu tac-
ku (engl. base point). Priusnite bilo gde u oblast za crtanje da biste zadali baznu
tacku; u njoj ce se pojavit Zuti kruzic a program ce pozvati da zadate odredi$nu tac-
ku. U oblasti za crtanje izaberite tacku u koju Zelite da premestite izabrane objekte.

Opcija X/Y

Kada je izabrano radio-dugme X/Y, izabrane objekte premeState tako Sto zadajete
relativne koordinate X1Y. Ispod radio-dugmeta pojavljuju se brojaciDelta X i Del-
ta Y pomocu kojih zadajete vrednosti odredisSnih koordinata.

Dugme Repeat
Kad god pritisnete dugme Repeat, izabrani objekti ce se pomeriti jo§ jednom za
isto zadato rastojanje.

Na slici 2-28 prikazano je premesdtanje izabranih objekata pomocu alatke Move
Entities. U ovom primery, za premestanje su izabrane gornja i desna stranica pravo-
ugaonika.

R i

> =
\\ \\ Pomeranjem kursora zadaje se
{konica bazne tatke

~— odrediSte objekata koji se premeStaju
— postavljena u zadatu baznu tatku

Slika 2-28 Premestange izabranih objekala
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Rotiranje skiciranih objekata

CommandManager: Sketch > Rotate Entities (Dodaje korisnik)
Meni: Tools > Sketch Tools > Rotate
-_?aleta alatki: Sketch > Rotate Entities (Dodaje korisnik)

Da biste rotirali skicirane objekte, aktivirajte alatku Rotate Entities tako
§to cete izabrati dugme Rotate Entities na panou Sketch Command-
Manager. Drugi nacin je da izaberete objekte, pritisnete desni taster
misa da bi se otvorjo priruéni meni, pa izaberete stavku Rotate Entities. Prikazuje se
pano za pode$avanje svojstava rotiranja - Rotate PropertyManager (slika 2-29) po-
mocu kojeg moZete da izaberete skicirane objekte ili oznake koje hocete da rotirate.

Stika 2-29 Pano za podesavanje svojstava rotiranja — Rotate PropertyManager

Objekd koje izaberete za rotiranje prikazuju se u polju Sketch items or annota-
tions na potpanou Entities to Rotate. Pritisnite unutar polja na potpanou Parame-
ters; program ce vas pozvati da zadate baznu tacku oko koje cete rotirati objekte.

Cim zadate baznu tacku, na potpanou Parameters bice istaknut broja¢ Aungle
koji sluZi za zadavanje ugla rotacije. Ugao rotacije mozete zadati 1 interaktivno -
povladenjem mi$a po ekranu.

Na slici 2-30 prikazano je rotiranje pravougaonika tako $to se kursor povlaci da
bi se definisao ugao rotacije. Kao bazna tacka rotacije izabrano je donje desno
teme pravougaonika,
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320°

Shika 2-30 Definisanje ugla rotacije pravougaonika pomocu misa

Promena veli¢ine skiciranih objekata

CommandManager: Sketch > Scale Entities (Dodaje korisnik)
Meni: Tools > Sketch Tools > Scale
Paleta alatkl: Sketch > Scale Entities (Dodaje korisnik)

Da biste promenili veli¢inu skiciranih objekata, aktivirajte alatku Scale
Entities tako §to cete na panou Sketch Tools CommandManager prij-
= usnuti dugme Scale Entities. Drugi nacin je da izaberete objekte, pri-
tisnete desni taster misa da bi se otvorio priruéni meni, pa izaberete stavku Scale
Entities. Prikazuje se pano za podeSavanje svojstava promene veli¢ine - Scale Pro-
pertyManager (slika 2-31) pomocdu kojeg birate skicirane objekte ili oznake kojima
treba da promenite velicinu.

Objekti koje izaberete da biste im promenili veli¢inu prikazuju se u polju
Sketch items or annotations na potpanou Entities to Scale. Kada izaberete objek-
te, pritisnite desni taster mifa; program ce pozvati da zadate baznu tacku koja ce
ostati nepromenjena kada promenite veli¢inu objekta.

Cim zadate baznu tacku, na potpanou Parameters bice istaknut broja¢ Scale
Factor koji sluZi za zadavanje faktora promene veli¢ine.

Ako potvrdite opciju Copy, prikazuje se brojac¢ Number of Copies pomocu ko-
Jeg zadajete broj kopija koje ce se napraviti pri promeni veli¢ine objekta, uz inkre-
mentalnu primenu zadatog faktora.
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Shka 2-31 Pano za podesavanje svojstava promene velicine
- Scale PropertyManager

Kopiranje skiciranih objekata

- Sketch -;-Oopy;intltres =

(Dadaje Korisnik)

Da blSl‘.C kopirali slucu ane objekte pritisnite dugrme Copy Entities na
panou Sketch CommandManager; prikazuje se pano za podesavanje
svojstava kopiranja - Copy PropertyManager (slika 2-32).

Slika 2-32  Pano za podesavanje svojstava kopiranja
- Copy PropertyManager






